Skip to content

RecipientDsnFields

Source code in docs_src/capo_ses/types/recipient_dsn_fields.py
class RecipientDsnFields(TypedDict, closed=True):
    final_recipient: NotRequired["capo_ses.types.address.Address"]
    """<p>The email address that the message was ultimately delivered to. This corresponds to the <code>Final-Recipient</code> in the DSN. If not specified, <code>FinalRecipient</code> is set to the <code>Recipient</code> specified in the <code>BouncedRecipientInfo</code> structure. Either <code>FinalRecipient</code> or the recipient in <code>BouncedRecipientInfo</code> must be a recipient of the original bounced message.</p> <note> <p>Do not prepend the <code>FinalRecipient</code> email address with <code>rfc 822;</code>, as described in <a href="https://tools.ietf.org/html/rfc3798">RFC 3798</a>.</p> </note>"""
    action: "capo_ses.types.dsn_action.DsnAction"
    """<p>The action performed by the reporting mail transfer agent (MTA) as a result of its attempt to deliver the message to the recipient address. This is required by <a href="https://tools.ietf.org/html/rfc3464">RFC 3464</a>.</p>"""
    remote_mta: NotRequired["capo_ses.types.remote_mta.RemoteMta"]
    """<p>The MTA to which the remote MTA attempted to deliver the message, formatted as specified in <a href="https://tools.ietf.org/html/rfc3464">RFC 3464</a> (<code>mta-name-type; mta-name</code>). This parameter typically applies only to propagating synchronous bounces.</p>"""
    status: "capo_ses.types.dsn_status.DsnStatus"
    """<p>The status code that indicates what went wrong. This is required by <a href="https://tools.ietf.org/html/rfc3464">RFC 3464</a>.</p>"""
    diagnostic_code: NotRequired["capo_ses.types.diagnostic_code.DiagnosticCode"]
    """<p>An extended explanation of what went wrong; this is usually an SMTP response. See <a href="https://tools.ietf.org/html/rfc3463">RFC 3463</a> for the correct formatting of this parameter.</p>"""
    last_attempt_date: NotRequired["capo_ses.types.last_attempt_date.LastAttemptDate"]
    """<p>The time the final delivery attempt was made, in <a href="https://www.ietf.org/rfc/rfc0822.txt">RFC 822</a> date-time format.</p>"""
    extension_fields: NotRequired[
        "capo_ses.types.extension_field_list.ExtensionFieldList"
    ]
    """<p>Additional X-headers to include in the DSN.</p>"""

action instance-attribute

action: DsnAction

The action performed by the reporting mail transfer agent (MTA) as a result of its attempt to deliver the message to the recipient address. This is required by RFC 3464.

diagnostic_code instance-attribute

diagnostic_code: NotRequired[DiagnosticCode]

An extended explanation of what went wrong; this is usually an SMTP response. See RFC 3463 for the correct formatting of this parameter.

extension_fields instance-attribute

extension_fields: NotRequired[ExtensionFieldList]

Additional X-headers to include in the DSN.

final_recipient instance-attribute

final_recipient: NotRequired[Address]

The email address that the message was ultimately delivered to. This corresponds to the Final-Recipient in the DSN. If not specified, FinalRecipient is set to the Recipient specified in the BouncedRecipientInfo structure. Either FinalRecipient or the recipient in BouncedRecipientInfo must be a recipient of the original bounced message.

Do not prepend the FinalRecipient email address with rfc 822;, as described in RFC 3798.

last_attempt_date instance-attribute

last_attempt_date: NotRequired[LastAttemptDate]

The time the final delivery attempt was made, in RFC 822 date-time format.

remote_mta instance-attribute

remote_mta: NotRequired[RemoteMta]

The MTA to which the remote MTA attempted to deliver the message, formatted as specified in RFC 3464 (mta-name-type; mta-name). This parameter typically applies only to propagating synchronous bounces.

status instance-attribute

status: DsnStatus

The status code that indicates what went wrong. This is required by RFC 3464.